re = /(?m)^(?![^\n]*?rolf[^\n]*$).*$/
str = 'roooolf
r123olf
123rolf123
rolf5623
123rolf
rollllf
rrrrrrolf
rolffff'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end