#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?m)^\s*([A-Z\s]*?(?:(ROYAL BANK)|(BARCLAY)).*)$"
Local $sString = "ROYAL BANK OF CANADA" & @CRLF & _
"ROYAL BANK OF CANADA" & @CRLF & _
"THE ROYAL BANK OF SCOTLAND PLC" & @CRLF & _
"THE ROYAL BANK OF SCOTLAND PLC" & @CRLF & _
"ROYAL BANK OF CANADA CAYMAN ISLANDS" & @CRLF & _
"RBC ROYAL BANK (TRINIDAD AND TOBAGO), LTD." & @CRLF & _
"RBC ROYAL BANK (TRINIDAD AND TOBAGO), LTD." & @CRLF & _
"THE ROYAL BANK OF SCOTLAND INTERNATIONAL, LTD." & @CRLF & _
"THE ROYAL BANK OF SCOTLAND INTERNATIONAL LTD." & @CRLF & _
"ROYAL BANK OF SCOTLAND, N.V." & @CRLF & _
"RBC ROYAL BANK (BAHAMAS), LTD." & @CRLF & _
"ROYAL BANK OF SCOTLAND PLC" & @CRLF & _
"ROYAL BANK OF SCOTLAND PLC" & @CRLF & _
"BARCLAYS BANK PLC" & @CRLF & _
"BARCLAYS BANK DELAWARE" & @CRLF & _
"BARCLAYS BANK OF GHANA, LTD." & @CRLF & _
"BARCLAYS BANK DELAWARE" & @CRLF & _
"BARCLAYCARD GERMANY" & @CRLF & _
"BARCLAYS BANK PLC" & @CRLF & _
"BARCLAYS BANK PLC"
Local $sSubst = "\0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)