const regex = /^(?:[[:^print:][:cntrl:]\s]|GIF89.{0,20})*<\?(?:php)?\s*\$yourmail\s*=.{0,40}?put your e-mail here.{0,190}?scam[\s\w]+by\s*walid\s*nabil.{0,70}?facebook\.com\/oreo0o.{0,50}?walid_nabil(?:[^>]+>\s*)?$/gis;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[[:^print:][:cntrl:]\\s]|GIF89.{0,20})*<\\?(?:php)?\\s*\\$yourmail\\s*=.{0,40}?put your e-mail here.{0,190}?scam[\\s\\w]+by\\s*walid\\s*nabil.{0,70}?facebook\\.com\\\/oreo0o.{0,50}?walid_nabil(?:[^>]+>\\s*)?$', 'gis')
const str = `<?php
\$yourmail = 'Tuto42@yahoo.com'; // PUT YOUR E-MAIL HERE
//To Open This Page : domain.com/?wal=mart
/*
\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$
\$ \$
\$ THIS SCAM WAS CREATED BY Walid Nabil (OREOO) \$
\$ FB:https://www.facebook.com/OReo0o \$
\$ ICQ:https://icq.im/Walid_Nabil \$
\$ 2020 \$
\$ \$
\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$
.----------------. .----------------. .----------------. .----------------. .----------------. .----------------.
| .--------------. || .--------------. || .--------------. || .--------------. || .--------------. || .--------------. |
| | ____ | || | _______ | || | _________ | || | ____ | || | ____ | || | ____ | |
| | .' \`. | || | |_ __ \\ | || | |_ ___ | | || | .' \`. | || | .' \`. | || | .' \`. | |
| | / .--. \\ | || | | |__) | | || | | |_ \\_| | || | / .--. \\ | || | / .--. \\ | || | / .--. \\ | |
| | | | | | | || | | __ / | || | | _| _ | || | | | | | | || | | | | | | || | | | | | | |
| | \\ \`--' / | || | _| | \\ \\_ | || | _| |___/ | | || | \\ \`--' / | || | \\ \`--' / | || | \\ \`--' / | |
| | \`.____.' | || | |____| |___| | || | |_________| | || | \`.____.' | || | \`.____.' | || | \`.____.' | |
| | | || | | || | | || | | || | | || | | |
| '--------------' || '--------------' || '--------------' || '--------------' || '--------------' || '--------------' |
'----------------' '----------------' '----------------' '----------------' '----------------' '----------------'
*/
?>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}