import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "en\\/(?:(?!history).)*?\\/";
final String string = "https://denissov.ru/en/barracuda_limited/\n"
+ "https://denissov.ru/en/barracuda_chronograph/\n"
+ "https://denissov.ru/en/barracuda_mechanical/\n"
+ "https://denissov.ru/en/speedster/\n"
+ "https://denissov.ru/en/free_rider/\n"
+ "https://denissov.ru/en/nau_automatic/\n"
+ "https://denissov.ru/en/lady_flower/\n"
+ "https://denissov.ru/en/enigma/\n"
+ "https://denissov.ru/en/number_one/\n"
+ "https://denissov.ru/en/history/\n"
+ "https://denissov.ru/en/wordhistory/\n"
+ "https://denissov.ru/en/historyword/\n"
+ "https://denissov.ru/en/histor_y/\n\n"
+ "https://denissov.ru/en/barracuda_limited/', '_top')\" style=\"cursor: pointer;\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}