using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:ftp|https?):\/\/(?!$|0\.0\.0\.0)(?:(?:(?:1?\d\d?|2[0-4]\d|25[0-5])(?:\.(?!$))?){4}|(?:[a-z\d]\.|[a-z\d](?:(?![-.]{2})[a-z\d-]){0,63}?[a-z\d]\.){1,63}?[a-z]{2,63})(?:[:/].*?)?$";
string input = @"---- GOOD ----
http://10.25.41.81:6000/api/File/GetContentResult?ObjectId=62ab059f5045ea0bb69e00d9
http://10.25.41.81:6600/api/File/GetContentResult?ObjectId=62ab0d9e5045ea0bb69e00e4
http://10.25.41.81:6600/api/File/GetContentResult?ObjectId=62a89a8c4f3326cc410c40ef
http://10.25.41.33:6600/api/File/GetContentResult?ObjectId=62ab04855045ea0bb69e00d7
https://websitebuilders.com
https://www.fceboo.k.com/Learn-the-Net-330002341216/
ftp://aeneas.m.it.edu/
https://en.wkip.ed-i.org/wiki/Internet#Terminolog
http://foo.com/blah_blah
http://foo.com/blah_blah/
http://foo.com/blah_blah_(wikipedia)
http://foo.com/blah_blah_(wikipedia)_(again)
http://www.example.com/wpstyle/?p=364
https://www.example.com/foo/?bar=baz&inga=42&quux
http://a.ws/䨹
http://foo.com/blah_(wikipedia)#cite-1
http://foo.com/blah_(wikipedia)_blah#cite-1
http://foo.com/unicode_(✪)_in_parens
http://foo.com/(something)?after=parens
http://code.google.com/events/#&product=browser
http://js.mp
ftp://foo.bar/baz
http://foo.bar/?q=Test%20URL-encoded%20stuff
http://1337.net
http://a.b-c.de
http://223.255.255.254
https://example.com/././foo
https://EXAMPLE.com/../x
https://example.org//
https://example.org/foo bar
http://foo.bar/foo(bar)baz quux
https://example.com:demo
https://r.com/r/zxVH
---- BAD ----
https://user:password@example.org/
http://userid:password@example.com:8080
http://userid:password@example.com:8080/
http://userid:password@example.com
http://userid:password@example.com/
http://userid@example.com
http://userid@example.com/
http://userid@example.com:8080
http://userid@example.com:8080/
file://loc%61lhost/
http://⌘.ws
http://⌘.ws/
http://☺.damowmow.com/
http://✪df.ws/123
http://[www.example.com]/
https://ex ample.org/
file://C|/demo
\example\..\demo/.\
https:example.org
https://////example.com///
http://0.0.0.0
http://3628126748
http://www.foo.bar./
http://a.b-.co
http://-a.b.co
http://-error-.invalid/
http://~_!$&'()*+,;=:%40:80%2f::::::@example.com
http://
http://.
http://..
http://../
http://?
http://??
http://??/
http://#
http://##
http://##/
http://foo.bar?q=Spaces should be encoded
//
//a
///a
///
http:///a
foo.com
rdar://1234
h://test
http:// shouldfail.com
:// should fail
ftps://foo.bar/
http://.www.foo.bar/
http://.www.foo.bar./
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}