import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:ftp|https?):\\/\\/(?!$|0\\.0\\.0\\.0)(?:(?:(?:1?\\d\\d?|2[0-4]\\d|25[0-5])(?:\\.(?!$))?){4}|(?:[a-z\\d]\\.|[a-z\\d](?:(?![-.]{2})[a-z\\d-]){0,63}?[a-z\\d]\\.){1,63}?[a-z]{2,63})(?:[:/].*?)?$";
final String string = "---- GOOD ----\n"
+ "http://10.25.41.81:6000/api/File/GetContentResult?ObjectId=62ab059f5045ea0bb69e00d9\n"
+ "http://10.25.41.81:6600/api/File/GetContentResult?ObjectId=62ab0d9e5045ea0bb69e00e4\n"
+ "http://10.25.41.81:6600/api/File/GetContentResult?ObjectId=62a89a8c4f3326cc410c40ef\n"
+ "http://10.25.41.33:6600/api/File/GetContentResult?ObjectId=62ab04855045ea0bb69e00d7\n"
+ "https://websitebuilders.com\n"
+ "https://www.fceboo.k.com/Learn-the-Net-330002341216/\n"
+ "ftp://aeneas.m.it.edu/\n"
+ "https://en.wkip.ed-i.org/wiki/Internet#Terminolog\n"
+ "http://foo.com/blah_blah\n"
+ "http://foo.com/blah_blah/\n"
+ "http://foo.com/blah_blah_(wikipedia)\n"
+ "http://foo.com/blah_blah_(wikipedia)_(again)\n"
+ "http://www.example.com/wpstyle/?p=364\n"
+ "https://www.example.com/foo/?bar=baz&inga=42&quux\n"
+ "http://a.ws/䨹\n"
+ "http://foo.com/blah_(wikipedia)#cite-1\n"
+ "http://foo.com/blah_(wikipedia)_blah#cite-1\n"
+ "http://foo.com/unicode_(✪)_in_parens\n"
+ "http://foo.com/(something)?after=parens\n"
+ "http://code.google.com/events/#&product=browser\n"
+ "http://js.mp\n"
+ "ftp://foo.bar/baz\n"
+ "http://foo.bar/?q=Test%20URL-encoded%20stuff\n"
+ "http://1337.net\n"
+ "http://a.b-c.de\n"
+ "http://223.255.255.254\n"
+ "https://example.com/././foo\n"
+ "https://EXAMPLE.com/../x\n"
+ "https://example.org//\n"
+ "https://example.org/foo bar\n"
+ "http://foo.bar/foo(bar)baz quux\n"
+ "https://example.com:demo\n"
+ "https://r.com/r/zxVH\n\n"
+ "---- BAD ----\n"
+ "https://user:password@example.org/\n"
+ "http://userid:password@example.com:8080\n"
+ "http://userid:password@example.com:8080/\n"
+ "http://userid:password@example.com\n"
+ "http://userid:password@example.com/\n"
+ "http://userid@example.com\n"
+ "http://userid@example.com/\n"
+ "http://userid@example.com:8080\n"
+ "http://userid@example.com:8080/\n"
+ "file://loc%61lhost/\n"
+ "http://⌘.ws\n"
+ "http://⌘.ws/\n"
+ "http://☺.damowmow.com/\n"
+ "http://✪df.ws/123\n"
+ "http://[www.example.com]/\n"
+ "https://ex ample.org/\n"
+ "file://C|/demo\n"
+ "\\example\\..\\demo/.\\\n"
+ "https:example.org\n"
+ "https://////example.com///\n"
+ "http://0.0.0.0\n"
+ "http://3628126748\n"
+ "http://www.foo.bar./\n"
+ "http://a.b-.co\n"
+ "http://-a.b.co\n"
+ "http://-error-.invalid/\n"
+ "http://~_!$&'()*+,;=:%40:80%2f::::::@example.com\n"
+ "http://\n"
+ "http://.\n"
+ "http://..\n"
+ "http://../\n"
+ "http://?\n"
+ "http://??\n"
+ "http://??/\n"
+ "http://#\n"
+ "http://##\n"
+ "http://##/\n"
+ "http://foo.bar?q=Spaces should be encoded\n"
+ "//\n"
+ "//a\n"
+ "///a\n"
+ "///\n"
+ "http:///a\n"
+ "foo.com\n"
+ "rdar://1234\n"
+ "h://test\n"
+ "http:// shouldfail.com\n"
+ ":// should fail\n"
+ "ftps://foo.bar/\n"
+ "http://.www.foo.bar/\n"
+ "http://.www.foo.bar./\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}