#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "b\.\s(\d{4})"
Local $sString = "21 Apr 1789 - 4 Mar 1797 John Adams (b. 1735 - d. 1826) Fed " & @CRLF & _
" 4 Mar 1797 - 4 Mar 1801 Thomas Jefferson (b. 1743 - d. 1826) D-R " & @CRLF & _
" 4 Mar 1801 - 4 Mar 1805 Aaron Burr (b. 1756 - d. 1836) D-R " & @CRLF & _
" 4 Mar 1805 - 20 Apr 1812 George Clinton (b. 1739 - d. 1812) D-R " & @CRLF & _
" 4 Mar 1813 - 23 Nov 1814 Elbridge Gerry (b. 1744 - d. 1814) D-R " & @CRLF & _
" 4 Mar 1817 - 4 Mar 1825 Daniel D. Tompkins (b. 1744 - d. 1825) D-R " & @CRLF & _
" 4 Mar 1825 - 28 Dec 1832 John Caldwell Calhoun (b. 1782 - d. 1850) Dem " & @CRLF & _
" 4 Mar 1833 - 4 Mar 1837 Martin van Buren (b. 1782 - d. 1862) Dem " & @CRLF & _
" 4 Mar 1837 - 4 Mar 1841 Richard Mentor Johnson (b. 1780 - d. 1850) Dem " & @CRLF & _
" 4 Mar 1841 - 4 Apr 1841 John Tyler (b. 1790 - d. 1862) Whg " & @CRLF & _
" 4 Mar 1845 - 4 Mar 1849 George Mifflin Dallas (b. 1792 - d. 1864) Dem "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")