package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\(\d+)(?:\))`)
var str = `hjgv ygkuy (1) erg erg ewr (2)erg erg erg er. (3)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}