$re = '/(?:\(\d+)(?:\))/';
$str = 'hjgv ygkuy (1) erg erg ewr (2)erg erg erg er. (3)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);