$re = '/\d{2} [A-Z] \d{1,4}/\d{4}/m';
$str = '63 C 397/2014
63 1 397/2014
AA C 397/2014';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);