// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{2} [A-Z] \d{1,4}/\d{4}").unwrap();
let string = "63 C 397/2014
63 1 397/2014
AA C 397/2014";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}