$re = '/^\d(\.\d{2}(\.\d{3})?)?$/m';
$str = '1
1.98
1.98.123
1.123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);