using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\A[^()]*+(\((?>[^()]|(?1))*+\)[^()]*+)++\z";
string input = @"foo(bar(bar(foo)))(foo1)bar1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}