re = /\A[^()]*+(\((?>[^()]|(?1))*+\)[^()]*+)++\z/m
str = 'foo(bar(bar(foo)))(foo1)bar1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end