$re = '/\A[^()]*+(\((?>[^()]|(?1))*+\)[^()]*+)++\z/m';
$str = 'foo(bar(bar(foo)))(foo1)bar1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);