using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<start>\$\$)(?<middle>.*?)(?=\$\$)(?P<end>\$\$)";
string input = @"some random text $$ hello world $$ some mo$$ random stuff $$e stuff";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}