$re = '/(?P<start>\$\$)(?<middle>.*?)(?=\$\$)(?P<end>\$\$)/m';
$str = 'some random text $$ hello world $$ some mo$$ random stuff $$e stuff';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);