re = /(?P<start>\$\$)(?<middle>.*?)(?=\$\$)(?P<end>\$\$)/m
str = 'some random text $$ hello world $$ some mo$$ random stuff $$e stuff'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end