using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^push|pop|shift|unshift|reverse|splice|sort|copyWithin|fill$";
string input = @"sort
push
pushNew
prefill
sortAscending
";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}