const regex = /^push|pop|shift|unshift|reverse|splice|sort|copyWithin|fill$/umg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^push|pop|shift|unshift|reverse|splice|sort|copyWithin|fill$', 'umg')
const str = `sort
push
pushNew
prefill
sortAscending
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}