package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^push|pop|shift|unshift|reverse|splice|sort|copyWithin|fill$`)
var str = `sort
push
pushNew
prefill
sortAscending
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}