using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\^((?<action>[A-Z])(?<num>\d+)?)+";
string input = @": label_msg
text ""^B3F2 Cut color 1 text from color 3 block""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}