re = /\^((?<action>[A-Z])(?<num>\d+)?)+/m
str = ': label_msg
text "^B3F2 Cut color 1 text from color 3 block"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end