package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\^((?<action>[A-Z])(?<num>\d+)?)+`)
var str = `: label_msg
text "^B3F2 Cut color 1 text from color 3 block"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}