package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-f0-9]{32}`)
var str = `"e95d9250251d470aa062fa1922dfa9a8"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}