const regex = /[a-f0-9]{32}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-f0-9]{32}', 'gm')
const str = `"e95d9250251d470aa062fa1922dfa9a8"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}