$re = '/[a-f0-9]{32}/m';
$str = '"e95d9250251d470aa062fa1922dfa9a8"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);