using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"1\..+?(?=2\.)";
string input = @"1. This is the first claim
spread across multiple lines
2. This is the second claim
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}