$re = '/1\..+?(?=2\.)/ms';
$str = '1. This is the first claim
spread across multiple lines
2. This is the second claim
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);