re = /1\..+?(?=2\.)/m
str = '1. This is the first claim
spread across multiple lines
2. This is the second claim
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end