using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(<XMLname\s*.*ipcode="").*?("".*)$";
string input = @"<XMLname attribute=value ipcode=""ee
ec""
attribute='value'>CDAT! dfg abc=""ddd"" <name>< attribute=value ipcode=""value""
attribute='value'></name>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}