re = /(?s)(<XMLname\s*.*ipcode=").*?(".*)$/m
str = '<XMLname attribute=value ipcode="ee
ec"
attribute=\'value\'>CDAT! dfg abc="ddd" <name>< attribute=value ipcode="value"
attribute=\'value\'></name>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end