// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?s)(<XMLname\s*.*ipcode=").*?(".*)$"#).unwrap();
let string = "<XMLname attribute=value ipcode=\"ee
ec\"
attribute='value'>CDAT! dfg abc=\"ddd\" <name>< attribute=value ipcode=\"value\"
attribute='value'></name>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}