#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^.+?\(|,)(?:\K[\w ]+(?:\([\S].*?\))?)"
Local $sString = "CREATE TABLE notes(id INTEGER,code DECIMAL (4,2),PRIMARY KEY (id))" & @CRLF & _
"CREATE TABLE notes(id INTEGER,code TEXT)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")