re = /(?:^.+?\(|,)(?:\K[\w ]+(?:\([\S].*?\))?)/m
str = 'CREATE TABLE notes(id INTEGER,code DECIMAL (4,2),PRIMARY KEY (id))
CREATE TABLE notes(id INTEGER,code TEXT)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end