$re = '/(?:^.+?\(|,)(?:\K[\w ]+(?:\([\S].*?\))?)/m';
$str = 'CREATE TABLE notes(id INTEGER,code DECIMAL (4,2),PRIMARY KEY (id))
CREATE TABLE notes(id INTEGER,code TEXT)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);