$re = '/(\'|\"|\^|\~|\;|\:|\°|\?|\&|\*|\+|\@|\#|\$|\%|\!|\\\\|\/|\(|\)|\||\=|\.|\,)/m';
$str = 'Teste / de $ Regex';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;