re = /(\'|\"|\^|\~|\;|\:|\°|\?|\&|\*|\+|\@|\#|\$|\%|\!|\\|\/|\(|\)|\||\=|\.|\,)/m
str = 'Teste / de $ Regex'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result