package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:(?:1000|[1-9][0-9][0-9]|[1-9][0-9]|[1-9]) ){0})(?:1000|[1-9][0-9][0-9]|[1-9][0-9]|[1-9])$`)
var str = `2
3 100
95 13 25
3 100
1000 1000 1000
1 2 3 4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}