// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?:(?:1000|[1-9][0-9][0-9]|[1-9][0-9]|[1-9]) ){0})(?:1000|[1-9][0-9][0-9]|[1-9][0-9]|[1-9])$").unwrap();
let string = "2
3 100
95 13 25
3 100
1000 1000 1000
1 2 3 4";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}