$re = '/^(?:(?:(?:1000|[1-9][0-9][0-9]|[1-9][0-9]|[1-9]) ){0})(?:1000|[1-9][0-9][0-9]|[1-9][0-9]|[1-9])$/m';
$str = '2
3 100
95 13 25
3 100
1000 1000 1000
1 2 3 4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);