using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Za-z0-9.]+@[A-Za-z0-9-]+\.[A-Za-z]{2,}(?:\s|$)";
string input = @"example@example.com
example@gmail.com
example@example.co.fr
john@smith.org";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}