re = /[A-Za-z0-9.]+@[A-Za-z0-9-]+\.[A-Za-z]{2,}(?:\s|$)/
str = 'example@example.com
example@gmail.com
example@example.co.fr
john@smith.org'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end