$re = '/[A-Za-z0-9.]+@[A-Za-z0-9-]+\.[A-Za-z]{2,}(?:\s|$)/';
$str = 'example@example.com
example@gmail.com
example@example.co.fr
john@smith.org';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);