package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s+|\s{2,}`)
var str = `
Hello World
Hello World
hello world
or if the very beginning has space
Hello World`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}