re = /^\s+|\s{2,}/m
str = '
Hello World
Hello World
hello world
or if the very beginning has space
Hello World'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end