$re = '/^\s+|\s{2,}/m';
$str = '
Hello World
Hello World
hello world
or if the very beginning has space
Hello World';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);