#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?i)[a-z]*?([a-z])[a-z]*?\1(?-i)(*SKIP)(*F)|[A-Z][a-z]{5}\.com$"
Local $sString = "Plpaso.com" & @CRLF & _
"Regxas.com" & @CRLF & _
"Amipsa.com" & @CRLF & _
"Ipsamo.com" & @CRLF & _
"Ipsama.com" & @CRLF & _
"Ipsima.com" & @CRLF & _
"IPszma.com" & @CRLF & _
"Ipsamo&.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")