$re = '/^(?i)[a-z]*?([a-z])[a-z]*?\1(?-i)(*SKIP)(*F)|[A-Z][a-z]{5}\.com$/m';
$str = 'Plpaso.com
Regxas.com
Amipsa.com
Ipsamo.com
Ipsama.com
Ipsima.com
IPszma.com
Ipsamo&.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);