const regex = /^(?i)[a-z]*?([a-z])[a-z]*?\1(?-i)(*SKIP)(*F)|[A-Z][a-z]{5}\.com$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?i)[a-z]*?([a-z])[a-z]*?\\1(?-i)(*SKIP)(*F)|[A-Z][a-z]{5}\\.com$', 'gm')
const str = `Plpaso.com
Regxas.com
Amipsa.com
Ipsamo.com
Ipsama.com
Ipsima.com
IPszma.com
Ipsamo&.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}